Read the rules before proceeding!

Topic: RE621 [1.3.0] (userscript) - a feature-packed toolkit and mass downloader for e621

Posted under e621 Tools and Applications

Thanks for working on this.

I have one request. I love being able to vote from the search page, but I hate having the thumbnails pop up larger. Popups on mouseover are disruptive. Can these two features be separated?

jaser said:
Thanks for working on this.

I have one request. I love being able to vote from the search page, but I hate having the thumbnails pop up larger. Popups on mouseover are disruptive. Can these two features be separated?

Sure, that's easy enough.

Edit: indeed, it was. Should be in the next release.

Updated

You could add an option to create different lists of subscribed tags. So it would be possible to create a list for, as an example, realistic/cartoony/feral/anthro/sfw/nsfw artists or different kinds of characters. I think it could be realised with a dropdown menu or a slide bar above or underneath the subscribed tags. I hope you understand what I mean. I had to use lots of google translate. And I hope I don't ask for to much in a to short period of time. ^^'

dubsthefox said:
You could add an option to create different lists of subscribed tags. So it would be possible to create a list for, as an example, realistic/cartoony/feral/anthro/sfw/nsfw artists or different kinds of characters. I think it could be realised with a dropdown menu or a slide bar above or underneath the subscribed tags. I hope you understand what I mean. I had to use lots of google translate. And I hope I don't ask for to much in a to short period of time. ^^'

Yeah, I get it. You want to have several separate subscription feeds instead of one.
It's definitely possible, and I do like the idea, but I don't know how soon it'll be added, since it would require a significant rewrite of the subscription system.
Keep the suggestions coming! While I can't promise that all of them will be implemented, I will do my best to do so.

I'm not certain that the subscriptions manager, settings import, or both are working properly for me.

If I try to import an old settings file, it just says 'Loading..." forever under the dialog box. If I back out and try clicking the button to import from local storage, it says 'Settings Imported!' but nothing is actually done far as I can tell. If I click on the bell icon in the top right, everything is blank apart from the info tab.

Moreover, if I try to manually add a pool to my subscriptions, nothing happens there, either. I click the subscribe button on the pool page (it'd be nice to have that button added within the post page like the older script did), it changes to subscribed, but then doesn't show up in my subscription list.

Looking in the browser console, it mentions a source map error regarding the extension, but my abilities to troubleshoot end there. The only thing that I can think of that might interfere with it is noscript, but I tried temporarily disabling it with no change in behavior. Thoughts?

logitech said: ...stuff

I didn't write the SubscriptionManager, but I did write the settings importer. Not sure what's going on with that - the sample file I have works. Could you send me your old settings file, so I can see what's going wrong with it?

As far as the the rest goes, I believe that this is normal. The script only notifies you when there has actually been an update to the thread / pool / tag / whatever. So, if there haven't been any new posts added to the pool, the notifications list would be empty. This may be a little confusing, I guess. Earlopain would be more qualified in addressing this question, though.

The lack of a source map is fine, it shouldn't impact anything.

bitwolfy said:
I didn't write the SubscriptionManager, but I did write the settings importer. Not sure what's going on with that - the sample file I have works. Could you send me your old settings file, so I can see what's going wrong with it?

As far as the the rest goes, I believe that this is normal. The script only notifies you when there has actually been an update to the thread / pool / tag / whatever. So, if there haven't been any new posts added to the pool, the notifications list would be empty. This may be a little confusing, I guess. Earlopain would be more qualified in addressing this question, though.

The lack of a source map is fine, it shouldn't impact anything.

Gotcha, it was nice with the 'old' script where it allowed you to see both pools with new posts to view and ones you're already up to date with. I suppose I could get used to that type system from the home page, but it'd be nice to have some method to view your complete subscription list in some other location (assuming it's not possible to do it from the bell flyout).

I'll PM you mysettings file so you can see if there's anything oddball there, hopefully that's all that's wrong...

logitech said:
Gotcha, it was nice with the 'old' script where it allowed you to see both pools with new posts to view and ones you're already up to date with. I suppose I could get used to that type system from the home page, but it'd be nice to have some method to view your complete subscription list in some other location (assuming it's not possible to do it from the bell flyout).

I'll PM you mysettings file so you can see if there's anything oddball there, hopefully that's all that's wrong...

I added the feature for viewing your already subscribed items to our issue tracker
I'll get to it over the next days.

Your exported settings are somehow not in the same format as the other sample data we have.
The data we have is base64 encoded, but yours is not. bitWolfy wrote the settings importer, so he'll see what he can do.

logitech said:
Gotcha, it was nice with the 'old' script where it allowed you to see both pools with new posts to view and ones you're already up to date with. I suppose I could get used to that type system from the home page, but it'd be nice to have some method to view your complete subscription list in some other location (assuming it's not possible to do it from the bell flyout).

I'll PM you mysettings file so you can see if there's anything oddball there, hopefully that's all that's wrong...

This script still shows you the "old" updates, but only the ones it records, not the ones that happened before you subscribed to something.
Having a list of all of your subscriptions would be useful.

The problem with your file is that it's not in a normal eSix Extend exported file format. Those are encoded in base64, with each module settings being recorded separately. For you, it's one huge JSON file.
I have no idea how this could happen, but since eSix Extend is so incredibly broken for me right now that I can't even open the settings page, I can't replicate this. I'm currently trying to format your file correctly, but no promises on that one.

Here's something you can do while the subscription list is being worked on. To check if the settings were correctly imported from local storage, simply export the current settings to file by clicking the "Export" button on the "Other" tab of the script settings. Open the downloaded file, and look for the section titled re621.PoolSubscriptions. If there ara a bunch of pool IDs in the data property, you should be good.

earlopain said:
snip

Perfect, thanks for the update. While we're on the topic would it be possible to also work in the ability to see progress in a given pool? The old script would give you a Pages Read/Total Pages counter next to each subscription entry. Additionally, the ability to disable thumbnail previews for pools and only list the titles would be nice to help declutter things a bit.

bitwolfy said:
snip

I looked at the exported results only seems to have the small handful of pools I tried to add manually, so the import from localstorage doesn't seem to be complete, unless the new script somehow overwrote the old one's data.

Thanks for all the hard work, both of you!

bitwolfy said:
Huh. It seems like the script couldn't parse your blacklist, of all things. Well, I wish that I knew that sooner.

I would like to know what broke it, though. Do you think that you could you send me your blacklist? Feel free to send me a DM or poke me on Discord if you are not comfortable posting that kind of thing in the forum.

Edit: I just released a hotfix version 1.0.2 that should address one possible cause of the crash. See if that helps.

My blacklist is empty! The hotfix worked, everything seems to be fine now.

ansen said: My blacklist is empty! The hotfix worked, everything seems to be fine now.

Yep. Turns out, if the blacklist is empty, the script not only failed to start a blacklist module, it failed to load all the modules after it, which is indicative of a much bigger problem that will be addressed in a future release. Meanwhile, I'm glad that this hotfix resolved your issue.

Updated

The resize-on-click function is causing issues for me as I'm trying to translate things: I'm frequently trying to place new notes, only to end up resizing the image and lose the note entirely. Could we get a toggle for that, or at least make it not happen during translation mode?

lafcadio said:
The resize-on-click function is causing issues for me as I'm trying to translate things: I'm frequently trying to place new notes, only to end up resizing the image and lose the note entirely. Could we get a toggle for that, or at least make it not happen during translation mode?

Sure. I'll do both.

Edit: I released a hotfix that will disable the resize-on-click functionality when editing notes. Check the first post in the thread for instructions on how to update the script properly. I hope this helps.

Edit2: Added a toggle switch to disable this feature completely. It's going to be in 1.1.

Updated

araptorinatophat said:
This will probably be a stupid question, but is this compatible with the violentmonkey script manager?

The current version has a fascinating issue that's causing posts to not be displayed on the search page. It's going to be fixed in 1.1, though, so there's that.
Not currently compatible with Greasemonkey either for an entirely different, but no less fascinating, reason.

Edit: Just fixed the issue with ViolentMonkey in v.1.0.4. Should be more or less compatible now.

Updated

You could add the "frequent tags", you can use while editing a post, to the mass editing tool.
And you could re-add the like/dislike count for comments if you access them from your profile.
If this is possible

dubsthefox said:
You could add the "frequent tags", you can use while editing a post, to the mass editing tool.
And you could re-add the like/dislike count for comments if you access them from your profile.
If this is possible

The "frequent tags" - I don't know if that's possible, but I'll look into it. At the very least, adding TinyAlias to that field should be possible, which would make editing tags a little easier.
The like/dislike count - I strongly suspect that it's a bug, which is going to get fixed at some point. If it isn't, sure, I'll add it back in.

Version 1.1

Changes
- Implemented a Mass Downloader utility. This module allows you to download posts by selecting them from the search page, as well as grouped by pools or sets.
- Re-worked the Thumbnail Enhancer. The size and shape of image previews can now be customized to your heart's content.
- Made collapsing tag categories persistant
- Added a way to reset module settings

Fixes
- Filtered out blacklisted posts from the subscriptions
- Ensured that notifications can get cleared while an update is running
- Fixed ForumSubscriptions notifying you about your own posts
- Fixed a display issue caused by posts being deleted
- Resolved a compatibility issue with ViolentMonkey
- Fixed an issue with ImageScaler conflicting with notes

Releases

Stable: script.user.js

Updating

Note that re-installing the script by clicking the link in the Releases section will wipe out your current settings.
Instead, manually update the script by clicking the tampermonkey icon in the toolbar, selecting Dashboard, and then left-clicking on the last update column for the script.
A new version will then be installed automatically.
It is also recommended that you set the update interval to daily in the settings, so that you can receive all the latest changes and fixes as soon as they come out.

dubsthefox said:
I found a bug. Enlarge on Hover doesn't work in mass editing mode. since the last update

That change was deliberate. Scaling up thumbnails interferes with the other modes a little.
Is that a feature that you use often? I can put it an option to re-enable it.
It would just have occasional visual bugs.

Updated

bitwolfy said:
Is that a feature that you use often?

Yes. Sometimes, if I am bored, I search for "-solo -duo -group -zero_pictured" and add the tags where it is missing.

bitwolfy said:
I can put it an option to re-enable it.

this would be very nice. It was very helpful. ^^

Is is possible to pin the top navigation/header bar in place after scrolling down? It's nice to not have to scroll way back up a forum thread or infinite scroll page to get to everything again.

logitech said:
Is is possible to pin the top navigation/header bar in place after scrolling down? It's nice to not have to scroll way back up a forum thread or infinite scroll page to get to everything again.

Sounds like a good idea to me. I was in some situations were I thought something like this would be nice myself.

lafcadio said:
Hotkeys should be disabled when viewing flash content.

Thanks for the info. I remeber the site provided hotkeys also having this problem.
This will be fixed in the next point release.

Updated

bitwolfy said:
The current version has a fascinating issue that's causing posts to not be displayed on the search page. It's going to be fixed in 1.1, though, so there's that.
Not currently compatible with Greasemonkey either for an entirely different, but no less fascinating, reason.

Edit: Just fixed the issue with ViolentMonkey in v.1.0.4. Should be more or less compatible now.

Thanks for the fix and response! 0/

lafcadio said: Hotkeys should be disabled when viewing flash content.

earlopain said: This will be fixed in the next point release.

Done! It's in patch 1.1.1.

araptorinatophat said: Thanks for the fix and response! 0/

No problem. Let us know if you run into any issues.

dubsthefox said: this would be very nice. It was very helpful. ^^

Added it in patch 1.1.2.

logitech said: Is is possible to pin the top navigation/header bar in place after scrolling down?

Possible, although I deeply dislike that concept. We'll see.
Remember that you can also navigate the first nine tabs with the number keys.

Not sure if this is something able to be 'fixed', but I've run into a bit of annoying behavior with infinite scrolling. If you click on a post, then go back a page in your browser, it loads the page # of post results that you were on before but doesn't display any newer posts. For example, you scroll halfway into the third page of results, click a post, hit back on your browser, and you are now only able to view posts from page 3 onward.

All that is well and good except if you wanted to see any newer posts than the page you stopped on. Since the browser has no history of you actually navigating through those newer pages of posts due to the way the infinite scrolling is coded, you can't just hit back again to go to those newer pages, you would need to manually change the URL in the address bar or re-submit your search.

Not really a deal-breaking behavior for me as I've mostly learned to open posts in new tabs whenever possible, but I still forget every now again and wonder where a bunch of posts disappeared to before I realize I'm not actually looking at the latest results. To me it seems the easiest implementation would be to make infinite scrolling work in both directions, but even my intermediate familiarity of web coding tells me that's probably easier said than done.

logitech said: snip

I'm with you on this one, that behavior is somewhat annoying. It's also the reason I added an option to double-click a thumbnail to open the post in a new tab, since I found myself opening everything in a new tab.
Implementing it isn't a problem, that's actually not too difficult. What I am concerned with is lag - having to load hundreds (or thousands) of images is rather bad for performance. I'll look into it when I get a chance.

One thing I don't like is how this script forces me to write notes for an artist when I'm either creating a new artist entry or editing an existing one that has no pre-existing notes. I've had to disable the script and reload the page just so I could actually submit my artist entry changes.

booruhitomi said:
One thing I don't like is how this script forces me to write notes for an artist when I'm either creating a new artist entry or editing an existing one that has no pre-existing notes. I've had to disable the script and reload the page just so I could actually submit my artist entry changes.

Whoops. That's not intentional.
It happens because when I first wrote this module, it was only intended for forum posts / comments, where having the textarea blank makes no sense. But when the module also got applied to other DText-formatted areas...
Yeah, this happened.

Edit: Fixed it in version 1.1.5

Updated

Nevermind, I figured out what you meant now by 'settings', after clicking on a bunch of the buttons, and noting they weren't from E621 normally.

Version 1.1.6-9

Changes
- The DNP cache is now updated daily, instead of on every release. This should keep it up to date, unless the API changes

Fixes
- Fixed zoom-on-hover functionality on the Popular page
- Fixed the export settings functionality
- Tweaked TinyAlias to stop blocking form submission
- Fixed inconsistent SubscriptionManager tab widths
- Hide PoolNavigator checkboxes when there is only one navbar visible

Thanks to JAK-Zero and clue for reporting these bugs.

Version 1.1.10-11

Fixes
- Specify the appropriate user-agent for API requests
- Fixed the FormattingHelper issues with the post editing form

Updated

That scrollbar is pretty ugly, I will try to remove that. Those other two are also valid points.
I don't actually remeber how the blacklist looked in the theme, gotta look it up.
I'll get back to it tomorrow, for now I'm of to bed.

albert12 said:
That scrollbar is pretty ugly, I will try to remove that. Those other two are also valid points.
I don't actually remeber how the blacklist looked in the theme, gotta look it up.
I'll get back to it tomorrow, for now I'm of to bed.

I have absolutely no idea what you are talking about.
Why are you spamming threads with random nonsense?

Patch 1.1.12-13

Another big thank you to JAK-Zero for his help in finding bugs.

Changes
- Made Alt+Enter work on all input fields, not just FormattingHelper ones

Fixes
- Resolved an issue with unbinding hotkeys
- Fixed a bug that caused issues with InfiniteScroll if InstantFilters were off
- Fixed a possible error when hovering over an thumbnail before the script has loaded

That scrollbar is pretty ugly, I will try to remove that. Those other two are also valid points.
I don't actually remeber how the blacklist looked in the theme, gotta look it up.
I'll get back to it tomorrow, for now I'm of to bed.

Btw, thanks for your redesign

albert12 said:
That scrollbar is pretty ugly, I will try to remove that. Those other two are also valid points.
I don't actually remeber how the blacklist looked in the theme, gotta look it up.
I'll get back to it tomorrow, for now I'm of to bed.

Btw, thanks for your redesign

Wow. Plagiarism much?

Version 1.2

The project underwent a major rewrite in order to create a chrome extension version of the script.

Changes
- Rewritten the Subscription Manager to be faster and more versatile
- Added a way to subscribe to post comment threads
- Tweaked Infinite Scroll to load all pages up to the current one when going back through history
- Switched the Theme Customizer to use the site's own settings for smoother transitions
- Applied Thumbnail Enhancer actions and effects to thumbnails on other pages
- Re-written the DNP list handling to remove a largely unnecessary external file
- Added a red dot to the forum tab in the header if there are new posts in the forum
- Improved Mass Downloader status text for fetching API data

Fixes
- Fixed subscription images sometimes missing initially while they load
- Fixed some font-awesome icons not being formatted correctly
- Fixed a potential error when using prev / next post hotkeys
- Fixed hotkeys not getting registered on some pages
- Throttled the Infinite Scroll event listener for the sake of performance
- Removed a duplicate e621 logo if the Header Customizer is disabled
- Split the script's metadata into a separate file for faster version checking
- Performance improvements

Releases

Userscript: script.user.js
Extension: re621.zip

Updating

Note that re-installing the script by clicking the link in the Releases section will wipe out your current settings.
Instead, manually update the script by clicking the tampermonkey icon in the toolbar, selecting Dashboard, and then left-clicking on the last update column for the script.
A new version will then be installed automatically.
It is also recommended that you set the update interval to daily in the settings, so that you can receive all the latest changes and fixes as soon as they come out.

Would it be possible to add a Favorite button alongside the Upvote and Downvote buttons in the Thumbnails module? I use Imagus to look at the full sized images instead of going to the page, and the ability to favorite from the search page would be amazing.

cherenthecat said:
Would it be possible to add a Favorite button alongside the Upvote and Downvote buttons in the Thumbnails module? I use Imagus to look at the full sized images instead of going to the page, and the ability to favorite from the search page would be amazing.

It is certainly possible. In fact, that button already exists, the code for it is just commented out.

There is an ongoing bug with the thumbnail buttons. Essentially, there is no way to determine whether you have already voted on / favorited the post without sending an extra API request. As in, one request for upvoted posts, one for downvoted ones, and now one for favorites.
This is why currently if the voting button didn't turn green / red after clicking on it, this means that a vote has actually been removed.

While accidentally removing a vote isn't that big of a deal, I don't want to risk having accidentally remove favorites.
I'll think about how to best implement this, but no promises.

dubsthefox said: a reload button for the subscribed tags would be neat

There is a "Manual Update" button on the info page that refreshes all subscription feeds.

bitwolfy said:
There is a "Manual Update" button on the info page...

ty, I didn't see it ^^'

edit: The refresh button doesn't work for me. It keeps showing me the same results as this morning. And I am sure there are new posts with my subscribed tags.

Updated

I'm not entirely sure why, but the blacklisted tags are disabled by default, i.e. showing me images with tags that are blacklisted. Is it a big or is there a setting somewhere I can't find?

Otherwise it's a very handy dandy toolset, big ups!

Updated

dubsthefox said: The refresh button doesn't work for me. It keeps showing me the same results as this morning.

Strange. I'll take a look.

foxmulder3333 said: I'm not entirely sure why, but the blacklisted tags are disabled by default, i.e. showing me images with tags that are blacklisted.

Do you mean that clicking on Enable all filters does not persist through page reload?

bitwolfy said:
Strange. I'll take a look.

Do you mean that clicking on Enable all filters does not persist through page reload?

Exactly, but for whatever reason it appears to work now when I test it, I don't think I've done anything other than turning my pc off and on.

Seems the old "Have you tried turning it off and and then on again?" continues to be a valid solution for problems, how about that.

Edit: It appears to be back to disabling all the blacklisted tags again, at first I thought it had something to do with having another window open, but that has now been debunked. Another thing I noticed as well is that the button for activating/deactivating all filters disappears as well when I enabled the script.

Updated

foxmulder3333 said: Exactly, but for whatever reason it appears to work now when I test it, I don't think I've done anything other than turning my pc off and on

Well, I'm glad that it fixed itself. Not quite sure why it wouldn't work, from what I remember, it uses the site's native functions.
I'll take a closer look at it regardless when I get a chance.

This was working just fine yesterday but when I logged on today it just acted like the normal site with the script not working at all. I tried everything I could think of to get it working again including doing a factory reset but it still just acts like I've not got the script installed. Any suggestions?

Edit (Not sure what happened but it just started working again, no effort on my part)

Updated

macawsyringes said:
This was working just fine yesterday but when I logged on today it just acted like the normal site with the script not working at all. I tried everything I could think of to get it working again including doing a factory reset but it still just acts like I've not got the script installed. Any suggestions?

Edit (Not sure what happened but it just started working again, no effort on my part)

Probably some sort of error during startup, otherwise you would get a popup window with the stack trace.
I'm guessing that it could be network related - failing to fetch a remote file or some such. That's the only scenario in which it could possibly start working again on its own.
If it happens again, try opening the browser's developer console to see if there are any messages in there.

Patch 1.2.1

Fixes
- Fixed thumbnails not displaying in Formatting Helper preview mode
- Removed a redundant background from the mass downloader sidebar section
- Resolved a layering problem resulting in site notices displaying under the thumbnails
- Fixed the forum thread subscriptions not working under certain circumstances
- Fixed the manual subscription update button sometimes marking old updates as new

OK, I am missing something. How do I subscribe to tags with this? I can see a subscription button for forums, but not tags. Has that not been implemented yet?

Small(?) idea that I've implemented in my local TMSU-based tagging system, maybe you would consider it:

  • blacklist-rule-based tag checking (if rule R is matched, show a flag F near the tags field)

Examples:

NCHARS: -solo -duo -group -zero_pictured

(show flag NCHARS if no 'number of characters' tags are present)
SEXES: -zero_pictured -male -female -herm -maleherm -andromorph -gynomorph -intersex -ambiguous_gender (show flag SEXES if it seems like there probably should be at least one such tag applied)

Example of a disabled rule:
#NCHARS: -solo -duo -group -zero_pictured (pretty obvious, but being able to disable/enable rules with a single character edit would be handy for switching between tagging projects)

invertadox said:
OK, I am missing something. How do I subscribe to tags with this? I can see a subscription button for forums, but not tags. Has that not been implemented yet?

It's implemented, just slightly obscure.
Hover the cursor over a tag in the list in the sidebar, and you should see a couple icons. The heart one subscribes / unsubscribes you from the tag.
I'll add a subscribe button to the tag's wiki page in the next release (or the one after, it's kinda complicated). Can't really think of a way to make it any more clear.

savageorange said: ...

It's really not a small idea.
Having custom flags like this would be quite helpful, I agree. Do you mean to have the flag notifications on the post thumbnail, in the editing form, or somewhere else entirely?
I'll have to think about how best to implement this.

Yeah, I wasn't sure how much reuse of the existing blacklisting code could be made. My implementation was pretty small partly because it didn't have to cope with metatags or styling.

I envisioned these locations:

  • 1. post/12345 : next to the Edit tags field. Maybe above? Whatever avoids taking away horizontal space from the tag edit box.
  • 2. post/index/* in non-edit mode : appended or prepended to the tooltip text, something like !! NCHARS SEXES !! (or in a different color rather than surrounded by !!, but I'm not sure how reliable that is cross-browser). I don't think the flags could be put on the thumbnail, because there could be arbitrarily many of them.
  • 3. post/index/* in edit mode : probably in a box above the tag editing box?

1 is the most important aspect IMO, but people would naturally want the other 2 locations for consistency and different use cases.

Ideally in cases 1 and 3, hovering over the relevant flag would show a tooltip with the text of the rule which triggered it.

savageorange said: ...

Re-using the blacklisting code isn't really practical.
Implementing the actual functionality turned out to be a lot easier than I thought. I've done that already.
Now it's time for me to agonize over making it look pretty.

Version 1.3.0

Changes
- Implemented Post Recommender, a tool that analyzes your favorites and suggests similar posts
- Added Custom Flags, a way to automatically highlight posts that match saved tag strings

Fixes
- Opening the notifications window automatically opens the tab with new content
- Made the forum thread title slightly more user-readable
- Performance tweaks and fixes

Releases

Userscript: script.user.js
Extension: re621.zip

Updating

Note that re-installing the script by clicking the link in the Releases section will wipe out your current settings.
Instead, manually update the script by clicking the tampermonkey icon in the toolbar, selecting Dashboard, and then left-clicking on the last update column for the script.
A new version will then be installed automatically.
It is also recommended that you set the update interval to daily in the settings, so that you can receive all the latest changes and fixes as soon as they come out.

bitwolfy said:
h3.Version 1.3.0

Changes
- Implemented Post Recommender, a tool that analyzes your favorites and suggests similar posts
- Added Custom Flags, a way to automatically highlight posts that match saved tag strings

Fixes
- Opening the notifications window automatically opens the tab with new content
- Made the forum thread title slightly more user-readable
- Performance tweaks and fixes

Releases

Userscript: script.user.js
Extension: re621.zip

Updating

Note that re-installing the script by clicking the link in the Releases section will wipe out your current settings.
Instead, manually update the script by clicking the tampermonkey icon in the toolbar, selecting Dashboard, and then left-clicking on the last update column for the script.
A new version will then be installed automatically.
It is also recommended that you set the update interval to daily in the settings, so that you can receive all the latest changes and fixes as soon as they come out.

How do you access the Post Recommender? I can't find any mention of it.

cherenthecat said: How do you access the Post Recommender? I can't find any mention of it.

It's in the sidebar on the search page, under "Random". Right here
There was an issue with this module in 1.3.0 release, though. A hotfix should be out shortly.

Hi Guys, I have encounter a problem with the script.

The script works well with classic Firefox but not with the developper edition.

I use TamperMonkey in the two case, in developper edition the script is activated when i come on e621 but nothing happens that should happen.

Do you have already encounter the problem ?

rendal said: The script works well with classic Firefox but not with the developper edition.

Why does every browser have like three separate editions these days, jeez.
I've downloaded it, and yeah, the issue occurs on my side as well. Investigating the causes right now.

Edit: It might be an issue with Tampermonkey, actually. I can't seem to be able to run any userscripts in this particular edition of Firefox.
Can you verify whether that is the case on your end as well?

Updated

  • 1
  • 2